MozTW 討論區

各項 Mozilla 相關軟體與技術討論
現在的時間是 2020-03-29, 23:34

所有顯示的時間為 UTC + 8 小時





發表新文章 回覆主題  [ 2 篇文章 ] 
發表人 內容
文章發表於 : 2011-11-20, 15:41 
離線
[MozTW 版主群]
頭像

註冊時間: 2008-10-10, 11:27
文章: 982
引言回覆:
This makes me sad. And it's a problem that's been magnified by the switch to rapid release. One of the strengths of Firefox is it's rich selection of add-ons. In fact, 85% of Firefox users have chosen to install an add-on. On average, those users have 5 add-ons installed. Firefox users really love their add-ons. So it's not surprising that they get frustrated when one of their favorite add-ons gets disabled because it's not marked as being compatible with the new Firefox update they just installed.

So I started working on a project to fix it. The end result will be that most add-ons will automatically be compatible with Firefox, starting with (hopefully) Firefox 10.

At the time of writing this, I've not yet finished the project. There are parts described below that I haven't completed yet. But it's progressed far enough to safely enable the new behavior on Nightly builds, starting with today's Nightly build (labelled 2011-11-18).

Many of the changes are also on Aurora, but disabled. If you want to test the new behavior, go into about:config and change the extensions.strictCompatibility preference to false (true to re-enable the old compatibility behavior). Once I have a couple more major bugs fixed, we'll make the call on whether to enable the new behavior by default on Aurora (which will ultimately become Firefox 10).


http://theunfocused.net/2011/11/19/solving-firefoxs-add-on-compatibility-problem/

在目前的 Aurora 與 Nightly 新增了 extensions.strictCompatibility 這個值。

預設為 true,也就是目前舊版本的相容模式。

若值為 false,則將啟動新式的相容模式,也就是等於內建了 Add-on Compatibility Reporter 套件的相容模式,

是這樣子嗎?

預計11版將預設啟動,也就是值為 false,但是一但啟用,難道不會對 Firefox 穩定性造成影響嗎?

_________________
圖檔


回頂端
Mozilla/5.0 (Windows NT 5.1; rv:9.0) Gecko/20100101 Firefox/9.0
 個人資料  
引用回覆  
文章發表於 : 2011-11-20, 20:27 
離線

註冊時間: 2011-05-02, 00:32
文章: 590
adam 寫:
若值為 false,則將啟動新式的相容模式,也就是等於內建了 Add-on Compatibility Reporter 套件的相容模式,
是這樣子嗎?
預計11版將預設啟動,也就是值為 false,但是一但啟用,難道不會對 Firefox 穩定性造成影響嗎?


圖片擷取自Nightly 版,表中應該超過一半套件是不相容11版:
圖檔

Nightly 剛在2天前將預設值換成false。跟ACR 不同的是,套件不但預設為啟用狀態,甚至不會提示為不相容所用的firefox 版本,感覺就像在用正式版。但此功能只會將支援4.0+的套件變成自動相容,而且沒有提供滙報不相容的功能。

至於穩定性方面……這功能是用家要求的,到時某某套件的某某功能失效時,再等待他們的怒哮吧。 :evil:


附加檔案:
FIREFOX addone.JPG [118.18 KiB]
被下載 539 次
回頂端
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0a1) Gecko/20111119 Firefox/11.0a1
 個人資料  
引用回覆  
顯示文章 :  排序  
發表新文章 回覆主題  [ 2 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:沒有註冊會員 和 1 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
Powered by phpBB® Forum Software © phpBB Group
正體中文語系由 竹貓星球 維護製作
© moztw.org, Mozilla Foundation
MozTW,Mozilla 台灣社群