MozTW 討論區

各項 Mozilla 相關軟體與技術討論
現在的時間是 2017-12-17, 10:14

所有顯示的時間為 UTC + 8 小時





發表新文章 回覆主題  [ 9 篇文章 ] 
發表人 內容
文章發表於 : 2017-11-21, 23:06 
離線

註冊時間: 2017-11-21, 22:44
文章: 5
我有兩台電腦,其中一台有這個狀況。

有這個狀況的那台電腦最近升級 Firefox 57 以後,我記不清楚是一升級完就馬上發現有這個問題,還是過了一兩天後來才發現,就是 youtube 沒聲音了。

試過安全模式,設定檔整個砍掉重練,問題一樣,移除再重新安裝的 firefox 57 用全新的設定檔沒改設定,沒安裝任何額外的 addon/plugin,直接去開 youtube 網頁,影像正常,沒有聲音。

同時間我另外裝 52 ESR 用隨便哪個設定檔去試都是正常的。

另外我用 flash 遊戲的網頁去試 57,聲音就有正常出來,只有 HTML5 player 會沒聲音。

疑難排解網頁裡有 HTML5 video/audio 的測試網頁,我連過去以後 audio 的 player 有顯示出來,但是按播放按鈕完全沒反應, video 則正常。

請問為什麼會這樣?


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-23, 08:09 
離線
頭像

註冊時間: 2013-11-03, 04:45
文章: 176
引言回覆:
Firefox 57.0 ...youtube 沒聲音...


建議改用
Firefox 免安裝 異X版 ==>
viewforum.php?f=43

Firefox 免安裝 異X版 52版 + "XP系統" 支援 "華銀(轉帳)外掛軟體HnbkEBankPlugin.exe" ;
Firefox 免安裝 異X版 自52版起(含57版) "非XP系統" 支援 "華銀(轉帳)安控軟體HncbNetBankServiceInstall.exe" -- 非外掛
註: 坊間的其它Firefox免安裝版 "暫不適用" 華銀安控軟體, 只能用舊版Firefox+外掛.


回頂端
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-23, 23:14 
離線

註冊時間: 2017-11-21, 22:44
文章: 5
不好意思社群版本我不會用。

還是想問一下為什麼我那台電腦會有那個狀況?


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-25, 13:07 
離線
頭像

註冊時間: 2013-11-03, 04:45
文章: 176
andju0529 寫:
不好意思社群版本我不會用。
還是想問一下為什麼我那台電腦會有那個狀況?


這是Firefox(發生在某些Win10版本上)的bug, 大大若在 "正常的" 那一台網址輸入
about:config
然後添加下列一行在youtube播片便會 "有影無聲":
user_pref("e10s.rollout.cohortSample.multi", "0.779271");

大大不妨按[Window鍵+R]輸入CMD, 查一下每一台PC的Win 10是安裝那一個版本.
大大若不想用社群的免安裝版, 可以退回Firefox 56. (或者換Win10的版本).


回頂端
Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-25, 17:16 
離線
頭像

註冊時間: 2005-04-17, 20:22
文章: 707
來自: ウルダハ不滅隊 - 少闘士
有網站可以試?
我在巴哈、YOUTUBE、伊莉都可以播HTML5,
話說FLASH GAME,不是要裝FLASH?跟HTML5沒什麼關係吧?
是用HTML5的網頁遊戲?

所以另外一台用57沒問題?


回頂端
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-25, 23:27 
離線

註冊時間: 2008-10-01, 06:02
文章: 12
用Firefox 57在這網頁播影片都有問題,播影片前的廣告沒有問題,但一播到影片內容就變了色,
http://www.fantv.hk/#/videopage/BJ00030


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-27, 18:43 
離線

註冊時間: 2017-11-21, 22:44
文章: 5
tools241 寫:
andju0529 寫:
不好意思社群版本我不會用。
還是想問一下為什麼我那台電腦會有那個狀況?


這是Firefox(發生在某些Win10版本上)的bug, 大大若在 "正常的" 那一台網址輸入
about:config
然後添加下列一行在youtube播片便會 "有影無聲":
user_pref("e10s.rollout.cohortSample.multi", "0.779271");

大大不妨按[Window鍵+R]輸入CMD, 查一下每一台PC的Win 10是安裝那一個版本.
大大若不想用社群的免安裝版, 可以退回Firefox 56. (或者換Win10的版本).


我兩台都是用 Win7,有更新到最新。
那有沒有什麼設定可以加到 about:config 就可以解決問題的?
或是 Mozilla 未來會修復這個 bug?


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
文章發表於 : 2017-11-27, 18:57 
離線

註冊時間: 2017-11-21, 22:44
文章: 5
天邪翼 寫:
有網站可以試?
我在巴哈、YOUTUBE、伊莉都可以播HTML5,
話說FLASH GAME,不是要裝FLASH?跟HTML5沒什麼關係吧?
是用HTML5的網頁遊戲?

所以另外一台用57沒問題?


我是跑 Flash Game 有聲音,來確定並非 Firefox 完全沒聲音,只是遇到 HTML5 沒聲音。
有問題的那台電腦用 57 不論任何 HTML5 影音都沒有聲音。


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
文章發表於 : 2017-12-17, 06:52 
離線

註冊時間: 2017-11-21, 22:44
文章: 5
回報一下,好像找到原因了。我不知道怎麼回報到mozilla,看有沒有人能幫我回報。

有問題的那台電腦我是用遠端桌面登入,在firefox 57以前,撥youtube影片聲音都能在遠端正常撥放,到了firefox57以後就失效了,結果今天用那台電腦本機登入以後,發現youtube影片在本機撥放是正常的。

總結一下問題:

firefox56及以前的版本可以由遠端電腦正常撥放youtube影片及html audio,到了firefox57變成不行。而且只有撥html audio才不行,遠端玩web flash game聲音還是可以正常撥放。


回頂端
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
 個人資料  
引用回覆  
顯示文章 :  排序  
發表新文章 回覆主題  [ 9 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:Bing [Bot], Exabot [Bot], Yahoo [Bot] 和 5 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
Powered by phpBB® Forum Software © phpBB Group
正體中文語系由 竹貓星球 維護製作
© moztw.org, Mozilla Foundation
MozTW,Mozilla 台灣社群