MozTW 討論區

各項 Mozilla 相關軟體與技術討論
現在的時間是 2021-04-10, 22:26

所有顯示的時間為 UTC + 8 小時





發表新文章 回覆主題  [ 6 篇文章 ] 
發表人 內容
文章發表於 : 2012-04-13, 05:27 
離線
頭像

註冊時間: 2011-05-24, 23:25
文章: 703
來自: Taiwan
https://addons.mozilla.org 的相容性說明很奇怪!

https://addons.mozilla.org/firefox/addon/Autopaste
寫 無法使用於 Firefox 11.0,可是實際離線安裝在 Firefox 11.0 卻可以?

https://addons.mozilla.org/thunderbird/addon/Autopaste
寫 Works with Thunderbird 1.0 - 11.*,可是實際離線安裝在 Thunderbird 11.0.1 卻說不相容?

解開 install.rdf 來看是寫:
<!--- firefox -->
<em:targetApplication>
<Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>1.0</em:minVersion>
<em:maxVersion>4.0.*</em:maxVersion>
</Description>
</em:targetApplication>

<!--- thunderbird -->
<em:targetApplication>
<Description>
<em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
<em:minVersion>1.0</em:minVersion>
<em:maxVersion>3.3a3pre</em:maxVersion>
</Description>
</em:targetApplication>

這又是什麼情形?

_________________
Firefox 開啟安全模式,停用個人設定、佈景主題及擴充套件(無附加元件)測試:
說明 > 重新啟動但停用附加元件(Firefox 4+)
Firefox Profile: 說明 > 疑難排解資訊 > 開啟資料夾
排版引擎:Firefox(Gecko), Opera(Presto), Google Chrome(WebKit),
Safari(WebKit), Internet Explorer(Trident), Konqueror(KHTML) :)


回頂端
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
 個人資料  
引用回覆  
文章發表於 : 2012-04-13, 09:39 
離線

註冊時間: 2011-05-02, 00:32
文章: 590
firefox 10 起所有支援4.0+ 的套件都是預設啟用及可安裝。thunderbird 10應該也是一樣。你可以直接在amo 內安裝firefox 的autopaste。

amo 裡面那個「相容於 」,是根據mozilla 的自動測試而產生(因為此套件只指明支援至4.0.*),mozilla 偵察到這套件有某個function(子程式?)已經過時,不再支援,所以可以肯定這套件有某些功能會失效。故此將之列為不兼容未來的版本。
* 這個「相容於」只測試到當時的beta 版本。

至於thunderbird 版本的autopaste,由於它寫到只支援至3.3a3pre,所以預設是不可安裝的。你需要自行修改install.rdf、修改about:config 參數、或者安裝add-on compatibility reporter 才能「啟用」該套件。
但為甚麼mozilla 也會為這個不支援4.0+ 的套件測試,我就不明白了……


回頂端
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120412 Firefox/14.0a1
 個人資料  
引用回覆  
文章發表於 : 2012-04-13, 20:50 
離線
頭像

註冊時間: 2011-05-24, 23:25
文章: 703
來自: Taiwan
Fanolian 寫:
firefox 10 起所有支援4.0+ 的套件都是預設啟用及可安裝。thunderbird 10應該也是一樣。你可以直接在amo 內安裝firefox 的autopaste。

這設計很奇怪,addons.mozilla.org 會偵測你的瀏覽器版本,不相容的在 addons.mozilla.org 搜尋框搜尋就會找不到該 addons,變成可以安裝的卻搜尋不到,要知道該 addons 的網址才能自行安裝...

說不相容卻又可以裝??!!
附加檔案:
說不相容卻又可以裝 自打嘴巴.png [22.84 KiB]
被下載 92 次

這個在 Fireofx 11 還是不能裝阿?
附加檔案:


Fanolian 寫:
至於thunderbird 版本的autopaste,由於它寫到只支援至3.3a3pre,所以預設是不可安裝的。你需要自行修改install.rdf、修改about:config 參數、或者安裝add-on compatibility reporter 才能「啟用」該套件。

我在 Thunderbird 11.0.1 裝了 Add-on Compatibility Reporter 1.1,
但在離線狀態下,還是不能安裝 signature_auto_paste_prefill_fourms-4.2-tb+fx.xpi
附加檔案:


Fanolian 寫:
但為甚麼mozilla 也會為這個不支援4.0+ 的套件測試,我就不明白了……

Mozilla 不是本來就應該為所有在 addons.mozilla.org 的套件做測試把關。

Add-on Compatibility Reporter 只報憂不報喜?!
在 Firefox 10+ 不是都預設相容了,裝了也不知要幹麻?!
使用者如果亂回報不相容,結果可信度會如何?

_________________
Firefox 開啟安全模式,停用個人設定、佈景主題及擴充套件(無附加元件)測試:
說明 > 重新啟動但停用附加元件(Firefox 4+)
Firefox Profile: 說明 > 疑難排解資訊 > 開啟資料夾
排版引擎:Firefox(Gecko), Opera(Presto), Google Chrome(WebKit),
Safari(WebKit), Internet Explorer(Trident), Konqueror(KHTML) :)


回頂端
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
 個人資料  
引用回覆  
文章發表於 : 2012-04-13, 21:14 
離線

註冊時間: 2011-05-02, 00:32
文章: 590
taglife 寫:
1. 這設計很奇怪,addons.mozilla.org 會偵測你的瀏覽器版本,不相容的在 addons.mozilla.org 搜尋框搜尋就會找不到該 addons,變成可以安裝的卻搜尋不到,要知道該 addons 的網址才能自行安裝...

2. 說不相容卻又可以裝??!!
附加檔案:
說不相容卻又可以裝 自打嘴巴.png
3. 這個在 Fireofx 11 還是不能裝阿?
附加檔案:
Firefox 10+ 不是說預設相容 但還是不能裝阿.png
4. 我在 Thunderbird 11.0.1 裝了 Add-on Compatibility Reporter 1.1,
但在離線狀態下,還是不能安裝 signature_auto_paste_prefill_fourms-4.2-tb+fx.xpi
附加檔案:
離線狀態下 還是不能安裝 Autopaste.png
5. Mozilla 不是本來就應該為所有在 addons.mozilla.org 的套件做測試把關。

Add-on Compatibility Reporter 只報憂不報喜?!
在 Firefox 10+ 不是都預設相容了,裝了也不知要幹麻?!
使用者如果亂回報不相容,結果可信度會如何?


1. 搜尋頁左邊可以選擇搜尋相容任何最近版本的套件,甚至是所有版本。

2. 不相容的意思,是已知firefox 不再支援該套件的某些程式碼(api?),故此該套件一定不能100% 正常運作。即使是標明相容,仍是有可能更firefox 相沖的。

3. 我已經有說過,firefox 10+ 預設支援「支援4.0+」的套件。只要套件寫到支援4.0+,firefox 10 以後就不需要額外的設定,也可以直接安裝該套件。但當中的風險要由安裝者承擔。
Extension Manager SlimList 在AMO 內的版本只相容至3.7a5pre,故此AMO 不容許你自由安裝。

4. 太久沒用Add-on Compatibility Reporter,不知道它的功能已改變,抱歉。AMO 有寫到:
引言回覆:
and it can no longer be used to force add-ons to be installed.
看來只剩修改install.rdf、修改about:config,或者安裝nightly tester tool 3個常用的方法。

5. 我沒有開發套件,所以也不太清楚AMO 的運作,不知道mozilla 會測試套件的甚麼部份…… 只知道最近新增了,簡單測試zombie compartment 的存在。我想mozilla 也不能替所有套件做所有的把關工作,還是要依靠firefox 用家社群的參與。


回頂端
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120412 Firefox/14.0a1
 個人資料  
引用回覆  
文章發表於 : 2012-04-14, 02:13 
離線
頭像

註冊時間: 2011-05-24, 23:25
文章: 703
來自: Taiwan
1. 今天才知道有這功能可以選,設計的太不明顯了 :oops:

2. 那這樣那個相容不相容不是都白寫了 :shock:

3. 所以說是 所有支援 4.0+ 的套件才是預設啟用及可安裝 對吧?有來源說明嗎?
http://www.mozilla.org/en-US/firefox/10.0/releasenotes
這邊都只有寫:Most add-ons are now compatible with new versions of Firefox by default
https://www.facebook.com/notes/mozilla- ... 3252729074
這邊寫:Firefox 10 起,附加元件將一律預設為相容

5. 覺得 Compatibility Reporter 應該內建而不是另外安裝,一般使用者根本不會去想要裝這玩意,所以也沒法回報,要回報還要裝... :roll:

_________________
Firefox 開啟安全模式,停用個人設定、佈景主題及擴充套件(無附加元件)測試:
說明 > 重新啟動但停用附加元件(Firefox 4+)
Firefox Profile: 說明 > 疑難排解資訊 > 開啟資料夾
排版引擎:Firefox(Gecko), Opera(Presto), Google Chrome(WebKit),
Safari(WebKit), Internet Explorer(Trident), Konqueror(KHTML) :)


回頂端
Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
 個人資料  
引用回覆  
文章發表於 : 2012-04-14, 07:31 
離線

註冊時間: 2011-05-02, 00:32
文章: 590
3. 支援4.0+ 的都預設兼容只是簡化了的說法(也是一般用家遇到的)。不會預設兼容的完整清單在
引言回覆:
Compatible By Default does not enable all extensions. The types not enabled include the following:

Add-ons marked to work with a Firefox version less than 4.0
Add-ons with binary components
Add-ons explicitly marked by the author as incompatible, i.e. opt-out of Compatible By Default
Add-ons tested and determined to not be compatible with a given version of Firefox, and marked as incompatible by Mozilla
Themes


回頂端
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20120413 Firefox/14.0a1
 個人資料  
引用回覆  
顯示文章 :  排序  
發表新文章 回覆主題  [ 6 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:Google Feedfetcher 和 46 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
Powered by phpBB® Forum Software © phpBB Group
正體中文語系由 竹貓星球 維護製作
© moztw.org, Mozilla Foundation
MozTW,Mozilla 台灣社群