MozTW 討論區

各項 Mozilla 相關軟體與技術討論
現在的時間是 2021-05-09, 08:58

所有顯示的時間為 UTC + 8 小時





發表新文章 回覆主題  [ 1 篇文章 ] 
發表人 內容
文章發表於 : 2012-07-11, 13:40 
離線
頭像

註冊時間: 2011-05-24, 23:25
文章: 703
來自: Taiwan
有些 iframe 嵌入的網站會顯示?! 有些不會是啥原因?!
好像跟瀏覽器又有關係,用 v3.5 全部都會顯示耶 :?:

test.htm
代碼:
<iframe frameborder="1" scrolling="yes" width="700" height="200" src="http://www.baidu.com"></iframe>
顯示<br/><br/>
<iframe frameborder="1" scrolling="yes" width="700" height="200" src="http:/www.google.com"></iframe>
不顯示<br/><br/>
<iframe frameborder="1" scrolling="yes" width="700" height="200" src="http://maps.google.com/?ie=UTF8&amp;ll=37.370157,-110.566406&amp;spn=28.922657,26.894531&amp;t=m&amp;z=4&amp;output=embed"></iframe>
顯示<br/><br/>
<iframe frameborder="1" scrolling="yes" width="700" height="200" src="http:/maps.google.com"></iframe>
不顯示<br/><br/>
<iframe frameborder="1" scrolling="yes" width="700" height="200" src="http:/friendfeed.com"></iframe>
不顯示<br/><br/>

用 IE8 疑似會提示:
此內容無法在框架中顯示:為了協助保護您在此網站所輸入的資訊安全性,此內容的發行者不允許在框架中顯示資訊。
原理是什麼?
但 Firefox 13 完全沒任何訊息 :?:

_________________
Firefox 開啟安全模式,停用個人設定、佈景主題及擴充套件(無附加元件)測試:
說明 > 重新啟動但停用附加元件(Firefox 4+)
Firefox Profile: 說明 > 疑難排解資訊 > 開啟資料夾
排版引擎:Firefox(Gecko), Opera(Presto), Google Chrome(WebKit),
Safari(WebKit), Internet Explorer(Trident), Konqueror(KHTML) :)


回頂端
Mozilla/5.0 (Windows NT 5.1; rv:13.0) Gecko/20100101 Firefox/13.0.1
 個人資料  
引用回覆  
顯示文章 :  排序  
發表新文章 回覆主題  [ 1 篇文章 ] 

所有顯示的時間為 UTC + 8 小時


誰在線上

正在瀏覽這個版面的使用者:Bing [Bot] 和 26 位訪客


不能 在這個版面發表主題
不能 在這個版面回覆主題
不能 在這個版面編輯您的文章
不能 在這個版面刪除您的文章
不能 在這個版面上傳附加檔案

搜尋:
前往 :  
Powered by phpBB® Forum Software © phpBB Group
正體中文語系由 竹貓星球 維護製作
© moztw.org, Mozilla Foundation
MozTW,Mozilla 台灣社群